天使漫步IT工作室天使漫步IT工作室

Minimum supported Gradle version is 2.14.1. Current version is 2.11解决办法

问题记录:

今天由于升级了android studio编译插件,但是升级软件后要求的gradle版本不能太低,而在系统内的gradle脚本却没有升级,导致了版本不对应。

Minimum supported Gradle version is 2.14.1.  Current version is 2.11
翻译:android studio最小支持的Gradle version为2.14.1,而当前系统内的版本为2.11。

命令行中敲入gradle -v出来的版本果然是2.11。


解决步骤:

  • 1.升级命令行的gradle的版本,可是怎么升级呢???升级步骤见:https://gradle.org/install/
    在下的是mac电脑,所以使用:brew upgrade gradle进行升级
  • 2.升级完以后,虽然命令行中gradle —version显示的升级的版本,如:version : xxx ,但是去编译工程的时候不见得就ok。这个时候需要清理下缓存:


清理步骤:

android studio—>file —> invalidate caches/restart —> 选择: invalidate caches/restart

AS 重启后,敲打命令运行即可。

------—关于grade 3.0 增量编译java的问题:
解决:降低Gradle 版本

本站原创,欢迎转载,转载敬请标明出处:天使漫步IT工作室 » Minimum supported Gradle version is 2.14.1. Current version is 2.11解决办法
添加新评论