天使漫步IT工作室天使漫步IT工作室

Android Stadio 3.0 更新Gradle 插件填坑

一、Java8确实快了

为了提升编译速度,这几天用上了 AS 3.0 和 Gradle 3.0 插件,不得不说不论是 AS 3.0,还是 Gradle 3.0 都变化非常大,具体的更新日志参考下官网,其中 Gradle 3.0的配置和可能遇到的问题可以说是非常详细了。Gradle 4.1-all 官方下载速度很慢,我直接放出来下载地址和相关官方文档地址吧。

网盘下载地址:https://pan.baidu.com/s/1o80wwu2
密码: h9nb
Android Studio
Gradle
配置属性官方迁移指南
下面来列决下我遇到的坑和解决方法:

二、配置属性的改动

Gradle 3.0 和之前有一点很大的不同就是配置属性的变化,详情可以参考上面列出的配置属性链接,这里我再具体的把两个关键字implementation和api解释一下。这里我使用的插件版本为build:gradle:3.0.0-beta5

三、api

api你可以简单的理解为之前的compile。举个例子,你使用api在lib.A下的build.gradle引用一个本地lib包,这里假设名为lib.A,那么当lib.B有改动的时候,重新编译不仅会编译lib.B,还会编译包括lib.A的所有通过api引用它的包。使用api进行引用,相当于把lib.B对外暴露了接口,这时候,假使有一个lib.C引用了lib.A,那么lib.C是可以直接使用lib.B的代码的。简单的画个图来解释下。

四、api引用示例.png

可以看到,通过api来引用实际上是和原来的compile一样的,虽然可以让lib.B的接口让lib.C来使用,但当lib.B有代码改动的时候,lib.A和lib.C都需要重新编译,无疑编译速度大大降低了。

五、implementation

如下图所示。implementation 引用的 lib 不会对外暴露自己的接口,也就是说,当lib.A implementation lib.B,lib.C implementation lib.A 的时候,如果lib.B发生了改变,那么只有lib.A会重新编译,lib.C将不会编译!这将大大减少编译时间。

![Uploading implementation引用实例_625757.png …]

总而言之,更好的方式就是尽量使用implementation来进行依赖,这样会大大改善工程的构建时间,除非你明确需要向外暴露当前 lib 依赖的接口时,才需要使用 api 依赖。

六、官方的 Maven 库

之后很多官方库的最新版本比如multidex等等,都会在官方的 Maven 库中进行更新,所以,如果你需要引用这些最新版本的库,你就需要配置官方的 Maven 地址

maven {
        url "https://maven.google.com"
}

如果你使用的是 4.0 版本以上的 gradle,那么可以直接使用 google() 来配置仓库:

repositories {
    google()
}

七、一些报错

    1. Error:Could not get unknown property ‘apkVariantData’ for object of type com.android.build.gradle.internal.api.ApplicationVariantImpl.

Gradle 3.0 的 api 有一些变化,所以如果你项目中引用了一些第三方 gradle 插件使用了一些旧的api,就会导致报错,比如这里就是因为apkVariantData这个指令已经从 gradle 3.0 剔除了。

解决方法首先是看看你引用的包的最新版本有没有适配3.0的。如果没有,要么你去下载它的插件源码,升级它的 gradle 插件到 3.0 ,再自己把过时的 api 换掉,要不就先暂时在项目中注释掉相关插件代码。

比如我这里就是因为AndResGuard使用了这个老 api 导致的报错。

    1. Error:The specified Android SDK Build Tools version (23.0.1) is ignored, as it is below the minimum supported version (25.0.0) for Android Gradle Plugin 3.0.0-beta5.Android SDK Build Tools 26.0.0 will be used.

Gradle 3.0 的最低支持 SDK Build Tools 版本为 25.0.0,所以如果你的项目中的 application 和 library 使用了比它低的版本,就会报这个错误。

官网的说明很清楚了:

资源压缩只与代码压缩协同工作。代码压缩器移除所有未使用的代码后,资源压缩器便可确定应用仍然使用的资源。这在您添加包含资源的代码库时体现得尤为明显 - 您必须移除未使用的库代码,使库资源变为未引用资源,才能通过资源压缩器将它们移除。
要启用资源压缩,请在 build.gradle 文件中将 shrinkResources 属性设置为 true(在用于代码压缩的 minifyEnabled 旁边)。例如:

android {
    ...
    buildTypes {
        release {
            shrinkResources true
            minifyEnabled true
            proguardFiles getDefaultProguardFile('proguard-android.txt'),
                    'proguard-rules.pro'
        }
    }
}

加上这些代码。问题即可解决。

    1. Error:java.lang.RuntimeException: Annotation processors must be explicitly declared now. The following dependencies on the compile classpath are found to contain annotation processor. Please add them to the annotationProcessor configuration.

这个问题是注解适配问题,新的 gradle 插件不再支持 annotation processors,如果需要使用需要显式声明:

defaultConfig{
    ...
    versionCode 1
    versionName 1.0
    javaCompileOptions {
            annotationProcessorOptions {
                includeCompileClasspath false
            }
        }
}
本站原创,欢迎转载,转载敬请标明出处:天使漫步IT工作室 » Android Stadio 3.0 更新Gradle 插件填坑
添加新评论