天使漫步IT工作室天使漫步IT工作室

Could not find method google() for arguments [] on repository container.解决办法

一、升级Android Stadio 3.0

IDE-Android Stadio升级到3.0以后,Gradle Plugin Build Tool的工具会被升级到3.0,这个Gradle Plugin不是Gradle本身,而是一个Android Stadio的插件,而3.0的插件要求最低的Gradle版本是4.1+,所以升级完以后IDE会要求用户升级Gradle的版本。

二、异常:Could not find method google()

Gradle插件升级(Gradle Plugin Build Tool 3.0)以后,对应的Gradle也要升级到4.1版本。如果未升级或者编译插件找不到对应的Gradle 4.1版本,那么就会出现Could not find method google() for arguments [] on repository container的报错,网上有人说去掉google()的方法即可,事实证明不行。

笔者想到的解决方法如下:

  • 1.将build.gradle中的classpath 'com.android.tools.build:gradle:3.0.0'降级,降级上一个版本即可,如2.3.3。
  • 2.确保Gradle 4.1版本升级完成,然后在IDE中的Perferences中的Gradle引用路径进行配置,如果在终端使用命令gradlew -v进行升级(前提是在gradle-wrapper.properties中distributionUrl的值https://services.gradle.org/distributions/gradle-4.1-all.zip),那么可以勾选Use default gradle wrapper。如果配置自定义路径,则可以勾选Use local gradle distribution,然后填入下载好的路径。
  • 3.更多的坑请参考文章:Android Stadio 3.0 更新Gradle 插件填坑
本站原创,欢迎转载,转载敬请标明出处:天使漫步IT工作室 » Could not find method google() for arguments [] on repository container.解决办法
添加新评论